Browse Source

env: add upper version constraint for pytest to keep compatibility with python3.5

https://github.com/fphammerle/ical2vdir/pull/26/commits/e28ca1ced412e23083e7adc8d9a936a521c07e88
Fabian Peter Hammerle 4 months ago
parent
commit
ebed8f8706
2 changed files with 4 additions and 2 deletions
  1. 3 1
      Pipfile
  2. 1 1
      Pipfile.lock

+ 3 - 1
Pipfile

@@ -21,13 +21,15 @@ black = {version = "==20.8b1", markers = "python_version >= '3.6'"}
 mypy = "*"
 pylint = "*"
 pylint-import-requirements = "*"
-pytest = "*"
+#pytest = "*"
 pytest-cov = "*"
 
 # python3.5 compatibility
 isort = "<5"
 # workaround https://github.com/pytest-dev/pytest/issues/3953
 pathlib2 = {version = "*", markers="python_version < '3.6'"}
+# https://github.com/pytest-dev/pytest/commit/179f4326df2b644f0ab73f78e4770dafcbdcd89f#diff-fa602a8a75dc9dcc92261bac5f533c2a85e34fcceaff63b3a3a81d9acde2fc52R52
+pytest = "<6.2"
 # https://github.com/jaraco/zipp/commit/05a3c52b4d41690e0471a2e283cffb500dc0329a
 zipp = "<2"
 

+ 1 - 1
Pipfile.lock

@@ -1,7 +1,7 @@
 {
     "_meta": {
         "hash": {
-            "sha256": "0ae8b03fe73773194ccb9523b6890df6f352d42e489e5c08026f18fd730e1485"
+            "sha256": "808a521362576e0c9b9250ff98dc4749714e543afbe5502e54617ccf28e61791"
         },
         "pipfile-spec": 6,
         "requires": {