Commit History

Author SHA1 Message Date
  dependabot[bot] cac5d69e47 build(deps): bump actions/setup-python from 2.3.0 to 2.3.1 9 months ago
  dependabot[bot] fbafea623d build(deps): bump actions/setup-python from 2.2.2 to 2.3.0 10 months ago
  dependabot[bot] d6592703a7 build(deps-dev): bump types-pyyaml from 6.0.0 to 6.0.1 10 months ago
  dependabot[bot] e7639f435a build(deps): bump actions/checkout from 2.3.5 to 2.4.0 10 months ago
  dependabot[bot] db68b3cf8c build(deps-dev): bump types-pyyaml from 5.4.12 to 6.0.0 11 months ago
  dependabot[bot] 0c5fc0fe05 build(deps): bump actions/checkout from 2.3.4 to 2.3.5 11 months ago
  dependabot[bot] e3f00dd5f8 build(deps-dev): bump types-pyyaml from 5.4.10 to 5.4.12 11 months ago
  Fabian Peter Hammerle 4ce2fe7e6f package metadata: add python3.10 classifier 11 months ago
  Fabian Peter Hammerle 5099ae1500 drop compatibility with python3.5 11 months ago
  dependabot[bot] 447a45fb3f build(deps-dev): bump pathlib2 from 2.3.5 to 2.3.6 1 year ago
  dependabot[bot] f1f8192ca8 build(deps-dev): bump mypy from 0.902 to 0.910 1 year ago
  dependabot[bot] ecee27c7ae build(deps-dev): bump mypy from 0.812 to 0.902 1 year ago
  Fabian Peter Hammerle 69d5782eb4 test env: added library stubs for pyyaml to prepare mypy upgrade from v0.812 to v0.902 1 year ago
  dependabot[bot] 0fd6841360 build(deps-dev): bump pytest-cov from 2.12.0 to 2.12.1 1 year ago
  dependabot[bot] 9b84255148 build(deps-dev): bump pytest-cov from 2.11.1 to 2.12.0 1 year ago
  Fabian Peter Hammerle 2b725964f5 dev env: add upper version constraint for `click` to keep compatibility with python3.5 1 year ago
  Fabian Peter Hammerle ca97f331e4 dev env: added upper version constraints for astroid & pylint to keep compatibility with python3.5 1 year ago
  dependabot[bot] 0b66f127ee build(deps-dev): bump mypy from 0.800 to 0.812 1 year ago
  Fabian Peter Hammerle 4644d19eaf test against python3.9 1 year ago
  Fabian Peter Hammerle 7ba62974af refactor pipeline config: detect name of top level module automatically 1 year ago
  dependabot[bot] dde01f1cce build(deps-dev): bump pylint from 2.6.0 to 2.6.2 1 year ago
  dependabot[bot] 083237fad8 build(deps-dev): bump mypy from 0.790 to 0.800 1 year ago
  dependabot[bot] 54d8549826 build(deps-dev): bump pytest-cov from 2.10.1 to 2.11.1 1 year ago
  Fabian Peter Hammerle a2686e38cd add upper version constraint for pyyaml to dev/test env to keep compatibility with python3.5 and to install_requires to avoid unexpected breaking changes 1 year ago
  Fabian Peter Hammerle e03d4dce85 env: add upper version constraint for pytest to keep compatibility with python3.5 1 year ago
  dependabot[bot] 3abb7684a9 build(deps-dev): bump importlib-metadata from 2.1.0 to 2.1.1 1 year ago
  Fabian Peter Hammerle af65a67357 upgrade black 1 year ago
  Fabian Peter Hammerle 17f34cd816 dev env: add upper version constraint for importlib-metadata to keep compatibility with python3.5 1 year ago
  dependabot[bot] 296fcd0503 build(deps-dev): bump pytest from 6.1.0 to 6.1.2 1 year ago
  dependabot[bot] 239abf87d8 build(deps-dev): bump mypy from 0.782 to 0.790 1 year ago