Browse Source

loosen version constraint to support PySwitchbot v0.12.0; update dev env

https://github.com/Danielhiversen/pySwitchbot/compare/0.11.0...0.12.0

https://github.com/fphammerle/switchbot-mqtt/issues/55#issuecomment-955401095
Fabian Peter Hammerle 2 months ago
parent
commit
6806749ea9
3 changed files with 5 additions and 5 deletions
  1. 1 1
      CHANGELOG.md
  2. 3 3
      Pipfile.lock
  3. 1 1
      setup.py

+ 1 - 1
CHANGELOG.md

@@ -6,7 +6,7 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
 
 ## [Unreleased]
 ### Added
-- support `PySwitchbot` `v0.11.0`
+- support `PySwitchbot` `v0.11.0` and `v0.12.0`
 
 ### Removed
 - compatibility with `python3.6`

+ 3 - 3
Pipfile.lock

@@ -30,10 +30,10 @@
         },
         "pyswitchbot": {
             "hashes": [
-                "sha256:32c071a484750b71c2128c5e1169274f80e9ad055a7bd6c3d2da45732c292ffc",
-                "sha256:d20e8b634c662f9a400f354e3b1b12af76781a3d4b5867221f99e558c3aa215d"
+                "sha256:6401a80e9ec14324201ee9a1bfca040bbe876a76a92e34e10c0b67d217880467",
+                "sha256:648aaff259f059c2fb8c3d2d4bc5e8f7f42d6ae4480d5b6bf30ca74d84da4247"
             ],
-            "version": "==0.11.0"
+            "version": "==0.12.0"
         },
         "switchbot-mqtt": {
             "editable": true,

+ 1 - 1
setup.py

@@ -81,7 +81,7 @@ setuptools.setup(
         # https://github.com/IanHarvey/bluepy/tree/v/1.3.0#release-notes
         "bluepy>=1.3.0,<2",
         # >=0.10.0 for SwitchbotCurtain.{update,get_position}
-        "PySwitchbot>=0.10.0,<0.12",
+        "PySwitchbot>=0.10.0,<0.13",
         "paho-mqtt<2",
     ],
     setup_requires=["setuptools_scm"],