Browse Source

dev env: re-add exceptiongroup, tomli & wrapt to fix pipeline

https://github.com/fphammerle/ical2vdir/commit/73686da37363c183bb4ccd8088aad9440b7045e6
https://github.com/fphammerle/ical2vdir/commit/897e1d2ac61d66ff77ff733d088e28ce51adfa63
https://github.com/fphammerle/ical2vdir/commit/28e34b8ab91853ec78f98c0abfc05a965d90190d
Fabian Peter Hammerle 2 months ago
parent
commit
527cf15655
2 changed files with 32 additions and 2 deletions
  1. 12 0
      Pipfile
  2. 20 2
      Pipfile.lock

+ 12 - 0
Pipfile

@@ -21,6 +21,18 @@ pytest-cov = "*"
 typing-extensions = "*"
 # mypy on python<3.8
 typed-ast = {markers = "python_version < '3.8'"}
+# >    File "[...]/lib/python3.10/site-packages/_pytest/_code/code.py", line 60, in <module>
+# >     from exceptiongroup import BaseExceptionGroup
+# > ModuleNotFoundError: No module named 'exceptiongroup'
+exceptiongroup = {markers = "python_version < '3.11'"}
+# >   File "[...]/lib/python3.10/site-packages/_pytest/config/findpaths.py", line 71, in load_config_dict_from_file
+# >     import tomli as tomllib
+# > ModuleNotFoundError: No module named 'tomli'
+tomli = {markers = "python_version < '3.11'"}
+# >   File "[...]/lib/python3.10/site-packages/astroid/decorators.py", line 16, in <module>
+# >     import wrapt
+# > ModuleNotFoundError: No module named 'wrapt'
+wrapt = "*"
 
 [requires]
 python_version = "3"

+ 20 - 2
Pipfile.lock

@@ -1,7 +1,7 @@
 {
     "_meta": {
         "hash": {
-            "sha256": "384dea99c5df1a59e338fca2b11c40a369b04c65f0f5fe19221646b0e7d108ec"
+            "sha256": "53b91dfbf5ed0f1f8eaa52f55ebcc99cda0fd55dd9f6e85bd3f7c8cfc3cb546c"
         },
         "pipfile-spec": 6,
         "requires": {
@@ -144,6 +144,15 @@
             "markers": "python_version >= '3.7'",
             "version": "==0.3.6"
         },
+        "exceptiongroup": {
+            "hashes": [
+                "sha256:4d6c0aa6dd825810941c792f53d7b8d71da26f5e5f84f20f9508e8f2d33b140a",
+                "sha256:73866f7f842ede6cb1daa42c4af078e2035e5f7607f0e2c762cc51bb31bbe7b2"
+            ],
+            "index": "pypi",
+            "markers": "python_version < '3.11'",
+            "version": "==1.0.1"
+        },
         "importlib-metadata": {
             "hashes": [
                 "sha256:da31db32b304314d044d3c12c79bd59e307889b287ad12ff387b3500835fc2ab",
@@ -323,6 +332,15 @@
             "markers": "python_version >= '3.7'",
             "version": "==65.5.1"
         },
+        "tomli": {
+            "hashes": [
+                "sha256:939de3e7a6161af0c887ef91b7d41a53e7c5a1ca976325f429cb46ea9bc30ecc",
+                "sha256:de526c12914f0c550d15924c62d72abc48d6fe7364aa87328337a31007fe8a4f"
+            ],
+            "index": "pypi",
+            "markers": "python_version < '3.11'",
+            "version": "==2.0.1"
+        },
         "tomlkit": {
             "hashes": [
                 "sha256:07de26b0d8cfc18f871aec595fda24d95b08fef89d147caa861939f37230bf4b",
@@ -431,7 +449,7 @@
                 "sha256:ee6acae74a2b91865910eef5e7de37dc6895ad96fa23603d1d27ea69df545015",
                 "sha256:ef3f72c9666bba2bab70d2a8b79f2c6d2c1a42a7f7e2b0ec83bb2f9e383950af"
             ],
-            "markers": "python_version >= '3.11'",
+            "index": "pypi",
             "version": "==1.14.1"
         },
         "zipp": {