2 Commits ed79fe6b9e ... aaf6491c78

Author SHA1 Message Date
  Fabian Peter Hammerle aaf6491c78 refactor test job: specify python version explicitly 1 week ago
  Fabian Peter Hammerle fd03943401 test against python3.10 1 week ago
4 changed files with 13 additions and 3 deletions
  1. 4 1
      .github/workflows/python.yml
  2. 6 0
      Pipfile
  3. 2 2
      Pipfile.lock
  4. 1 0
      setup.py

+ 4 - 1
.github/workflows/python.yml

@@ -36,6 +36,7 @@ jobs:
         - '3.7'
         - '3.8'
         - '3.9'
+        - '3.10'
       fail-fast: false
     steps:
     - uses: actions/checkout@v2.3.4
@@ -44,7 +45,9 @@ jobs:
         python-version: ${{ matrix.python-version }}
     - run: pip install --upgrade pipenv==2020.8.13
     # by default pipenv picks the latest version in PATH
-    - run: pipenv --python "$(which python)" install --deploy --dev
+    - run: pipenv install --python "$PYTHON_VERSION" --deploy --dev
+      env:
+        PYTHON_VERSION: ${{ matrix.python-version }}
     - run: pipenv graph
     - run: pipenv run pytest --cov="$(cat *.egg-info/top_level.txt)" --cov-report=term-missing --cov-fail-under=100
     - run: pipenv run pylint --load-plugins=pylint_import_requirements "$(cat *.egg-info/top_level.txt)"

+ 6 - 0
Pipfile

@@ -16,6 +16,12 @@ pylint-import-requirements = "*"
 pytest = "*"
 pytest-cov = "*"
 
+# python3.10 compatibility
+# >   File "[...]/lib/python3.10/site-packages/mypy/main.py", line 11, in <module>
+# >     from typing_extensions import Final, NoReturn
+# > ModuleNotFoundError: No module named 'typing_extensions'
+typing_extensions = "*"
+
 [requires]
 python_version = "3"
 

+ 2 - 2
Pipfile.lock

@@ -1,7 +1,7 @@
 {
     "_meta": {
         "hash": {
-            "sha256": "35694f2f0f715db4ff89a1d2665e2279325f375ee8122d2ee782e414c29e3cbd"
+            "sha256": "aaf97c6f909c05fadff82a4b8b7de164ea4c2bbecf11efaf552f76fe5005105d"
         },
         "pipfile-spec": 6,
         "requires": {
@@ -452,7 +452,7 @@
                 "sha256:d8226d10bc02a29bcc81df19a26e56a9647f8b0a6d4a83924139f4a8b01f17b7",
                 "sha256:f1d25edafde516b146ecd0613dabcc61409817af4766fbbcfb8d1ad4ec441a34"
             ],
-            "markers": "python_version < '3.10'",
+            "index": "pypi",
             "version": "==3.10.0.2"
         },
         "urllib3": {

+ 1 - 0
setup.py

@@ -46,6 +46,7 @@ setuptools.setup(
         "Programming Language :: Python :: 3.7",
         "Programming Language :: Python :: 3.8",
         "Programming Language :: Python :: 3.9",
+        "Programming Language :: Python :: 3.10",
         "Topic :: Utilities",
     ],
     entry_points={