Browse Source

pipeline: enable pylint_import_requirements explicitly

https://github.com/fphammerle/switchbot-mqtt/commit/663ae02dfff638bc24e0ef1dead12795f87184b6
Fabian Peter Hammerle 11 months ago
parent
commit
f1edde3f6c
2 changed files with 2 additions and 6 deletions
  1. 2 2
      .github/workflows/python.yml
  2. 0 4
      .pylintrc

+ 2 - 2
.github/workflows/python.yml

@@ -32,12 +32,12 @@ jobs:
            pipenv install --dev importlib-metadata;
            fi
     - run: pipenv graph
-    - run: pipenv run pylint ical2vdir
+    - run: pipenv run pylint --load-plugins=pylint_import_requirements ical2vdir
     # https://github.com/PyCQA/pylint/issues/352
     # disable parse-error due to:
     # > tests/resources/__init__.py:1:0: F0010: error while code parsing: Unable to load file tests/resources/__init__.py:
     # > [Errno 2] No such file or directory: 'tests/resources/__init__.py' (parse-error)
-    - run: pipenv run pylint --disable=missing-requirement --disable=parse-error tests/*
+    - run: pipenv run pylint --disable=parse-error tests/*
     - run: pipenv run mypy ical2vdir tests
     - run: pipenv run pytest --cov=ical2vdir --cov-report=term-missing --cov-fail-under=100
     - run: pipenv run black --check .

+ 0 - 4
.pylintrc

@@ -1,7 +1,3 @@
-[MASTER]
-
-load-plugins=pylint_import_requirements
-
 [MESSAGE CONTROL]
 
 disable=bad-continuation, # black