Browse Source

dev env: added upper version constraints for astroid & pylint to keep compatibility with python3.5

Fabian Peter Hammerle 1 month ago
parent
commit
b2f23fe029
2 changed files with 7 additions and 2 deletions
  1. 5 1
      Pipfile
  2. 2 1
      Pipfile.lock

+ 5 - 1
Pipfile

@@ -11,17 +11,21 @@ ical2vdir = {editable = true,path = "."}
 # https://github.com/psf/black/commit/e74117f172e29e8a980e2c9de929ad50d3769150#diff-2eeaed663bd0d25b7e608891384b7298R51
 black = {version = "==20.8b1", markers = "python_version >= '3.6'"}
 mypy = "*"
-pylint = "*"
+#pylint = "*"
 pylint-import-requirements = "*"
 #pytest = "*"
 pytest-cov = "*"
 
 # python3.5 compatibility
+# https://github.com/PyCQA/astroid/commit/d81f07becf3243a84e0baaa3493ce74cafed8022#diff-60f61ab7a8d1910d86d9fda2261620314edcae5894d5aaa236b821c7256badd7R52
+astroid = "<2.5"
 # https://github.com/python/importlib_metadata/commit/107f9029fd5807c6579b881db19e11a0488f0675
 importlib-metadata = "<3"
 isort = "<5"
 # workaround https://github.com/pytest-dev/pytest/issues/3953
 pathlib2 = {version = "*", markers="python_version < '3.6'"}
+# https://github.com/PyCQA/pylint/commit/6e2de8e3a2e2c5586e876ca305f0844bdd822db3
+pylint = "<2.7"
 # https://github.com/pytest-dev/pytest/commit/179f4326df2b644f0ab73f78e4770dafcbdcd89f#diff-fa602a8a75dc9dcc92261bac5f533c2a85e34fcceaff63b3a3a81d9acde2fc52R52
 pytest = "<6.2"
 # https://github.com/jaraco/zipp/commit/05a3c52b4d41690e0471a2e283cffb500dc0329a

+ 2 - 1
Pipfile.lock

@@ -1,7 +1,7 @@
 {
     "_meta": {
         "hash": {
-            "sha256": "ca0da756931c8e63419a02f9127c6a63afd965deb1865a8635a569e5f9746368"
+            "sha256": "be3af46dbc1e52d015169c1526ae6bc0500dd751845ada7e721df977752da3f7"
         },
         "pipfile-spec": 6,
         "requires": {
@@ -62,6 +62,7 @@
                 "sha256:2f4078c2a41bf377eea06d71c9d2ba4eb8f6b1af2135bec27bbbb7d8f12bb703",
                 "sha256:bc58d83eb610252fd8de6363e39d4f1d0619c894b0ed24603b881c02e64c7386"
             ],
+            "index": "pypi",
             "version": "==2.4.2"
         },
         "attrs": {