Browse Source

test against python3.9

Fabian Peter Hammerle 2 months ago
parent
commit
0d8c2b5a4b
3 changed files with 16 additions and 4 deletions
  1. 15 3
      .github/workflows/python.yml
  2. 0 1
      CHANGELOG.md
  3. 1 0
      setup.py

+ 15 - 3
.github/workflows/python.yml

@@ -24,7 +24,7 @@ jobs:
     - uses: actions/setup-python@v1
       with:
         python-version: ${{ matrix.python-version }}
-    - run: pip install --upgrade pipenv==2020.8.13
+    - run: pip install --upgrade pipenv==2020.11.15
     - run: pipenv install --python "$PYTHON_VERSION" --deploy --dev
       env:
         PYTHON_VERSION: ${{ matrix.python-version }}
@@ -39,6 +39,7 @@ jobs:
         - 3.6
         - 3.7
         - 3.8
+        - 3.9
         pandas-version:
         - '' # locked version
         - 0.21.*
@@ -85,6 +86,14 @@ jobs:
         # https://github.com/fphammerle/freesurfer-volume-reader/runs/1937182916
         - python-version: 3.8
           pandas-version: 1.1.*
+        - python-version: 3.9
+          pandas-version: 0.21.*
+        - python-version: 3.9
+          pandas-version: 0.22.*
+        - python-version: 3.9
+          pandas-version: 0.23.*
+        - python-version: 3.9
+          pandas-version: 0.24.*
       fail-fast: false
     steps:
     - uses: actions/checkout@v1
@@ -101,12 +110,15 @@ jobs:
         PANDAS_VERSION: ${{ matrix.pandas-version }}
     - run: pipenv graph
     - run: pipenv run pytest --cov="$(cat *.egg-info/top_level.txt)" --cov-report=term-missing --cov-fail-under=100
-    - run: pipenv run pylint --load-plugins=pylint_import_requirements "$(cat *.egg-info/top_level.txt)"
+    # https://github.com/PyCQA/pylint/issues/3882
+    - run: python3 -c 'import sys; sys.exit(sys.version_info < (3, 9))'
+        || pipenv run pylint --load-plugins=pylint_import_requirements "$(cat *.egg-info/top_level.txt)"
     # https://github.com/PyCQA/pylint/issues/352
     # disable parse-error due to:
     # > tests/resources/__init__.py:1:0: F0010: error while code parsing: Unable to load file tests/resources/__init__.py:
     # > [Errno 2] No such file or directory: 'tests/resources/__init__.py' (parse-error)
-    - run: pipenv run pylint --disable=parse-error tests/*
+    - run: python3 -c 'import sys; sys.exit(sys.version_info < (3, 9))'
+        || pipenv run pylint --disable=parse-error tests/*
     - run: pipenv run mypy "$(cat *.egg-info/top_level.txt)" tests
     # >=1.9.0 to detect branch name
     # https://github.com/coveralls-clients/coveralls-python/pull/207

+ 0 - 1
CHANGELOG.md

@@ -11,7 +11,6 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
 ## [2.1.0] - 2020-07-11
 ### Added
 - support `pandas` `v1.*`
-- package metadata: added `python3.8` classifier
 
 ## [2.0.0] - 2019-08-08
 ### Changed

+ 1 - 0
setup.py

@@ -38,6 +38,7 @@ setuptools.setup(
         "Programming Language :: Python :: 3.6",
         "Programming Language :: Python :: 3.7",
         "Programming Language :: Python :: 3.8",
+        "Programming Language :: Python :: 3.9",
         "Topic :: Scientific/Engineering :: Information Analysis",
         "Topic :: Scientific/Engineering :: Medical Science Apps.",
         "Topic :: Utilities",