Browse Source

env: added pathlib2 for python3.5 to fix ImportError when running pytest

Fabian Peter Hammerle 2 weeks ago
parent
commit
66e1ea2ece
2 changed files with 12 additions and 1 deletions
  1. 2 0
      Pipfile
  2. 10 1
      Pipfile.lock

+ 2 - 0
Pipfile

@@ -9,6 +9,8 @@ acpi-backlight = {editable = true, path = "."}
 [dev-packages]
 pytest = "*"
 
+# workaround https://github.com/pytest-dev/pytest/issues/3953
+pathlib2 = {version = "*", markers="python_version < '3.6'"}
 # zipp v2.0.0 dropped support for python3.5
 # https://github.com/jaraco/zipp/commit/05a3c52b4d41690e0471a2e283cffb500dc0329a
 zipp = "<2"

+ 10 - 1
Pipfile.lock

@@ -1,7 +1,7 @@
 {
     "_meta": {
         "hash": {
-            "sha256": "b10e6c4a46734a8aacff32bb37fa2b8c8acbd45340fb17b5e9b446512dfe0b70"
+            "sha256": "90ead5fbcddf0ef730c9398cc1df5a5f169e67ea8afdc61eb41bcc2a8942f3ed"
         },
         "pipfile-spec": 6,
         "requires": {},
@@ -49,6 +49,15 @@
             ],
             "version": "==20.4"
         },
+        "pathlib2": {
+            "hashes": [
+                "sha256:0ec8205a157c80d7acc301c0b18fbd5d44fe655968f5d947b6ecef5290fc35db",
+                "sha256:6cd9a47b597b37cc57de1c05e56fb1a1c9cc9fab04fe78c29acd090418529868"
+            ],
+            "index": "pypi",
+            "markers": "python_version < '3.6'",
+            "version": "==2.3.5"
+        },
         "pluggy": {
             "hashes": [
                 "sha256:15b2acde666561e1298d71b523007ed7364de07029219b604cf808bfa1c765b0",